Punchh Platform Campaign Processing Delays

Incident Report for Punchh AU

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 08:56 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 05:30 PDT

Update

We are continuing to work to resolve this issue. Thank you for your patience and understanding.
Posted Sep 06, 2025 - 13:38 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 06, 2025 - 11:19 PDT

Investigating

We are currently experiencing delays in processing campaigns. Our team is actively working to resolve the issue as quickly as possible.
Customer Impact:
• Campaigns may take longer than usual to be sent out.
• You might experience delays in receiving real-time data and updates.
• The Punchh Dashboard will show that your campaign is scheduled instead of processing or processed after than the scheduled start time
• If you're still seeing this behavior 2 hours after the scheduled start time, please submit a support case

We apologize for any inconvenience this may cause and appreciate your patience. Updates will be provided as more information becomes available. Thank you for your understanding.
Posted Sep 06, 2025 - 10:28 PDT